DrawContextGetViewRectangle Method |
Gets the rectangle that represents the extent (in 2D) of the Revit view where rendering takes place.
Namespace: Autodesk.Revit.DB.DirectContext3DAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static Rectangle GetViewRectangle()
Public Shared Function GetViewRectangle As Rectangle
public:
static Rectangle^ GetViewRectangle()
static member GetViewRectangle : unit -> Rectangle
Return Value
Rectangle
The view rectangle.
ExceptionsException | Condition |
---|
InvalidOperationException |
This DrawContext is not available because Revit is not currently rendering. In general, this DrawContext must be used in the scope of the RenderScene() callback of IDirectContext3DServer.
|
See Also