Obtains the curve loops which bound the wall's elevation profile.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public static IList<CurveLoop> GetElevationProfile( Wall pVWall ) |
Visual Basic |
---|
Public Shared Function GetElevationProfile ( _ pVWall As Wall _ ) As IList(Of CurveLoop) |
Visual C++ |
---|
public: static IList<CurveLoop^>^ GetElevationProfile( Wall^ pVWall ) |
Parameters
- pVWall
- Type: Autodesk.Revit.DB..::..Wall
The wall.
Return Value
The collection of curve loops.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The wall does not have an elevation profile. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |