Indicates whether executions of the service is recorded in documents or not.
Namespace: Autodesk.Revit.DB.ExternalServiceAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public bool IsRecordable { get; set; } |
Visual Basic |
---|
Public Property IsRecordable As Boolean Get Set |
Visual C++ |
---|
public: property bool IsRecordable { bool get (); void set (bool value); } |
Remarks
When a recordable service is executed in a document, a record about the executed server (or servers) is stored in the document's history. This allows active servers to be synchronized next time a saved document is opened in Revit.
Executions of a recordable service in a document must happen inside a transaction.