ExternalServiceOptionsIsRecordable Property |
Indicates whether executions of the service is recorded in documents or not.
Namespace: Autodesk.Revit.DB.ExternalServiceAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsRecordable { get; set; }
Public Property IsRecordable As Boolean
Get
Set
public:
property bool IsRecordable {
bool get ();
void set (bool value);
}
member IsRecordable : bool with get, set
Property Value
Boolean
ExceptionsException | Condition |
---|
ArgumentException |
When setting this property: A service that doens't support activation should not be recordable.
|
RemarksWhen a recordable service is executed in a document, a record about the executed
server (or servers) is stored in the document's history. This allows active servers
to be synchronized next time a saved document is opened in Revit.
Executions of a recordable service in a document must happen inside a transaction.
See Also