Constructs the specification of vertex format from a numerical representation.
Namespace: Autodesk.Revit.DB.DirectContext3DAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public VertexFormat( VertexFormatBits vertexFormatBits ) |
Visual Basic |
---|
Public Sub New ( _ vertexFormatBits As VertexFormatBits _ ) |
Visual C++ |
---|
public: VertexFormat( VertexFormatBits vertexFormatBits ) |
Parameters
- vertexFormatBits
- Type: Autodesk.Revit.DB.DirectContext3D..::..VertexFormatBits
The numerical representation of the vertex format.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.Exceptions..::..InvalidOperationException | This VertexFormat is not available because Revit is not currently rendering. In general, this VertexFormat must be used in the scope of the RenderScene() callback of IDirectContext3DServer. |