Vertex format (i.e., the type of data associated with a vertex) represented as a number.
Namespace: Autodesk.Revit.DB.DirectContext3DAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public enum VertexFormatBits |
Visual Basic |
---|
Public Enumeration VertexFormatBits |
Visual C++ |
---|
public enum class VertexFormatBits |
Members
Member name | Description |
---|---|
Position | Vertex format consisting of a position. |
PositionNormal | Vertex format consisting of a position and a normal vector. |
PositionColored | Vertex format consisting of a position and a color. |
PositionNormalColored | Vertex format consisting of a position, a normal vector, and a color. |
Remarks
VertexFormatBits can be used to specify the vertex format in the creation of the following objects:
VertexFormatBits is not to be confused with VertexFormat. The latter type of object is associated with low-level graphics
functionality and may become invalid. VertexFormat is needed to submit a set of vertex and index buffers for rendering (see
DrawContext).