Constructs the specification of vertex format from a numerical representation.
Namespace: Autodesk.Revit.DB.DirectContext3DAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic VertexFormat(
VertexFormatBits vertexFormatBits
)
Public Sub New (
vertexFormatBits As VertexFormatBits
)
public:
VertexFormat(
VertexFormatBits vertexFormatBits
)
new :
vertexFormatBits : VertexFormatBits -> VertexFormat
Parameters
- vertexFormatBits VertexFormatBits
-
The numerical representation of the vertex format.
ExceptionsException | Condition |
---|
ArgumentOutOfRangeException |
A value passed for an enumeration argument is not a member of that enumeration
|
InvalidOperationException |
This VertexFormat is not available because Revit is not currently rendering. In general, this VertexFormat must be used in the scope of the RenderScene() callback of IDirectContext3DServer.
|
See Also