Creates a line pattern segment with given type and length.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public LinePatternSegment( LinePatternSegmentType type, double length ) |
Visual Basic |
---|
Public Sub New ( _ type As LinePatternSegmentType, _ length As Double _ ) |
Visual C++ |
---|
public: LinePatternSegment( LinePatternSegmentType type, double length ) |
Parameters
- type
- Type: Autodesk.Revit.DB..::..LinePatternSegmentType
The segment type.
- length
- Type: System..::..Double
The length.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |