Obtains a special snapshot of the geometry of an in-place wall element suitable for export.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public static GeometryElement GetGeometryFromInplaceWall( FamilyInstance pFamInstWallElem ) |
Visual Basic |
---|
Public Shared Function GetGeometryFromInplaceWall ( _ pFamInstWallElem As FamilyInstance _ ) As GeometryElement |
Visual C++ |
---|
public: static GeometryElement^ GetGeometryFromInplaceWall( FamilyInstance^ pFamInstWallElem ) |
Parameters
- pFamInstWallElem
- Type: Autodesk.Revit.DB..::..FamilyInstance
The in-place wall instance.
Return Value
The in-place wall geometry. Returns nullNothingnullptra null reference (Nothing in Visual Basic) if there is no special geometry for the wall needed for export; the standard geometry of the wall can be used.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |