ExporterIFCUtilsGetGeometryFromInplaceWall Method |
Obtains a special snapshot of the geometry of an in-place wall element suitable for export.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static GeometryElement GetGeometryFromInplaceWall(
FamilyInstance pFamInstWallElem
)
Public Shared Function GetGeometryFromInplaceWall (
pFamInstWallElem As FamilyInstance
) As GeometryElement
public:
static GeometryElement^ GetGeometryFromInplaceWall(
FamilyInstance^ pFamInstWallElem
)
static member GetGeometryFromInplaceWall :
pFamInstWallElem : FamilyInstance -> GeometryElement
Parameters
- pFamInstWallElem FamilyInstance
-
The in-place wall instance.
Return Value
GeometryElement
The in-place wall geometry. Returns
if there is no special
geometry for the wall needed for export; the standard geometry of the wall can be used.
Exceptions
See Also