Returns the projected area of the room, unscaled.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public static double ComputeRoofProjectedArea( Element pElem ) |
Visual Basic |
---|
Public Shared Function ComputeRoofProjectedArea ( _ pElem As Element _ ) As Double |
Visual C++ |
---|
public: static double ComputeRoofProjectedArea( Element^ pElem ) |
Parameters
- pElem
- Type: Autodesk.Revit.DB..::..Element
The roof.
Return Value
The projected area.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |