Constructs a extension instance with a control and ok action handler.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public TabbedDialogExtension( UserControl userControl, TabbedDialogAction onOK ) |
Visual Basic |
---|
Public Sub New ( _ userControl As UserControl, _ onOK As TabbedDialogAction _ ) |
Visual C++ |
---|
public: TabbedDialogExtension( UserControl^ userControl, TabbedDialogAction^ onOK ) |
Parameters
- userControl
- Type: System.Windows.Controls..::..UserControl
The control.
- onOK
- Type: Autodesk.Revit.UI..::..TabbedDialogAction
The ok action handler.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when userControl or onOK is nullNothingnullptra null reference (Nothing in Visual Basic). |
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when userControl is already bound to another tabbed dialog. |