Contains the information required to create and implement the behavior for the new tab inside
the Revit options dialog.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public class TabbedDialogExtension |
Visual Basic |
---|
Public Class TabbedDialogExtension |
Visual C++ |
---|
public ref class TabbedDialogExtension |
Remarks
Each page has an associated user interface control and the handlers of buttons Cancel, Restore Defaults
and help can optionally be set. The size of the control is limited to 305 (height) x 288 (width) in physical pixels.
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.UI..::..TabbedDialogExtension
Autodesk.Revit.UI..::..TabbedDialogExtension