Identifies if the family instance has its own geometry, or uses the symbol's geometry with a transform.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public static bool UsesInstanceGeometry( FamilyInstance familyInstance ) |
Visual Basic |
---|
Public Shared Function UsesInstanceGeometry ( _ familyInstance As FamilyInstance _ ) As Boolean |
Visual C++ |
---|
public: static bool UsesInstanceGeometry( FamilyInstance^ familyInstance ) |
Parameters
- familyInstance
- Type: Autodesk.Revit.DB..::..FamilyInstance
The family instance.
Return Value
True if the instance has its own geometry. False if the symbol's geometry is used.
Remarks
A Family Instance can have its own copy of geometry, or use the symbol's geometry with a transform.
This method identifies the source of this family instance's geometry.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |