ExporterIFCUtilsUsesInstanceGeometry Method |
Identifies if the family instance has its own geometry, or uses the symbol's geometry with a transform.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool UsesInstanceGeometry(
FamilyInstance familyInstance
)
Public Shared Function UsesInstanceGeometry (
familyInstance As FamilyInstance
) As Boolean
public:
static bool UsesInstanceGeometry(
FamilyInstance^ familyInstance
)
static member UsesInstanceGeometry :
familyInstance : FamilyInstance -> bool
Parameters
- familyInstance FamilyInstance
-
The family instance.
Return Value
Boolean
True if the instance has its own geometry. False if the symbol's geometry is used.
Exceptions
Remarks
A Family Instance can have its own copy of geometry, or use the symbol's geometry with a transform.
This method identifies the source of this family instance's geometry.
See Also