Changes the size of the selection of fabrication parts.
Namespace: Autodesk.Revit.DB.FabricationAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018.2
Syntax
C# |
---|
public FabricationNetworkChangeServiceResult ChangeSize( ISet<ElementId> selection, ISet<FabricationPartSizeMap> fabricationPartSizeMaps ) |
Visual Basic |
---|
Public Function ChangeSize ( _ selection As ISet(Of ElementId), _ fabricationPartSizeMaps As ISet(Of FabricationPartSizeMap) _ ) As FabricationNetworkChangeServiceResult |
Visual C++ |
---|
public: FabricationNetworkChangeServiceResult ChangeSize( ISet<ElementId^>^ selection, ISet<FabricationPartSizeMap^>^ fabricationPartSizeMaps ) |
Parameters
- selection
- Type: System.Collections.Generic..::..ISet<(Of <(<'ElementId>)>)>
The set of element identifiers of fabrication parts to change the size for.
- fabricationPartSizeMaps
- Type: System.Collections.Generic..::..ISet<(Of <(<'FabricationPartSizeMap>)>)>
The map containing the original sizes for the straights to the new sizes.
Remarks
After this method has been invoked, call:
- GetStraightsThatWereNotChanged()()()() to get a set of fabrication part straight element identifiers that were not changed.
- [!:GetElementsThatHadFailures] to get a set of fabrication part element identifiers that had failures.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The selection contains invalid elements to change. -or- The fabrication size map is empty. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | No fabrication configuration is loaded. |