Gets the set of fabrication part straights that were not changed due to either there was no corresponding part in the service or the size was out of range.

Namespace: Autodesk.Revit.DB.Fabrication
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2018.2

Syntax

C#
public ISet<ElementId> GetStraightsThatWereNotChanged()
Visual Basic
Public Function GetStraightsThatWereNotChanged As ISet(Of ElementId)
Visual C++
public:
ISet<ElementId^>^ GetStraightsThatWereNotChanged()

Remarks

This set of element identifiers is only available after the ChangeService or ChangeSize method has been invoked, and returns FabricationNetworkChangeServiceResult::Enum::PartialFailure.

See Also