This class represents the fabrication part size map for straights allowing the sizes to be changed from a user interface for multiple straights with diffent sizes.
Namespace: Autodesk.Revit.DB.FabricationAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018.2
Syntax
C# |
---|
public class FabricationPartSizeMap : IDisposable |
Visual Basic |
---|
Public Class FabricationPartSizeMap _ Implements IDisposable |
Visual C++ |
---|
public ref class FabricationPartSizeMap : IDisposable |
Remarks
This is used as the data container for the FabricationPartSizeMapSet typeDef for crs:Set or Autodesk.Revit.DB.Fabrication.FabricationPartSizeMap for ISet so a list of sizes can be generated to allow the user to select a size and map it to another.
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB.Fabrication..::..FabricationPartSizeMap
Autodesk.Revit.DB.Fabrication..::..FabricationPartSizeMap