Creates object from an array of domain point vectors
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public FieldValues( IList<VectorAtPoint> vectorAtPoint ) |
Visual Basic |
---|
Public Sub New ( _ vectorAtPoint As IList(Of VectorAtPoint) _ ) |
Visual C++ |
---|
public: FieldValues( IList<VectorAtPoint^>^ vectorAtPoint ) |
Parameters
- vectorAtPoint
- Type: System.Collections.Generic..::..IList<(Of <(<'VectorAtPoint>)>)>
Array of vectors, each corresponding to a domain point
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | Members of vectorAtPoint contain different numbers of measurements |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |