Stores vectors at one domain point.
Each vector corresponds to a "measurement" for which this vector was calculated.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public class VectorAtPoint : ValueAtPointBase |
Visual Basic |
---|
Public Class VectorAtPoint _ Inherits ValueAtPointBase |
Visual C++ |
---|
public ref class VectorAtPoint : public ValueAtPointBase |
Examples

// Place analysis results in the form of vectors at each of a beam or column's analytical model curve Curve curve = familyInstance.GetAnalyticalModel().GetCurve(); Transform transform = familyInstance.GetTransform(); int index = spatialFieldManager.AddSpatialFieldPrimitive(curve, Transform.Identity); IList<double> doubleList = new List<double>(); doubleList.Add(curve.GetEndParameter(0)); // vectors will be at each end of the analytical model curve doubleList.Add(curve.GetEndParameter(1)); FieldDomainPointsByParameter pointsByParameter = new FieldDomainPointsByParameter(doubleList); List<XYZ> xyzList = new List<XYZ>(); xyzList.Add(curve.ComputeDerivatives(0, true).BasisX.Normalize()); // vectors will be tangent to the curve at its ends IList<VectorAtPoint> vectorList = new List<VectorAtPoint>(); vectorList.Add(new VectorAtPoint(xyzList)); xyzList.Clear(); xyzList.Add(curve.ComputeDerivatives(1, true).BasisX.Normalize().Negate()); vectorList.Add(new VectorAtPoint(xyzList)); FieldValues fieldValues = new FieldValues(vectorList);

' Place analysis results in the form of vectors at each of a beam or column's analytical model curve Dim curve As Curve = familyInstance.GetAnalyticalModel().GetCurve() Dim transform__1 As Transform = familyInstance.GetTransform() Dim index As Integer = spatialFieldManager.AddSpatialFieldPrimitive(curve, Transform.Identity) Dim doubleList As IList(Of Double) = New List(Of Double)() doubleList.Add(curve.GetEndParameter(0)) ' vectors will be at each end of the analytical model curve doubleList.Add(curve.GetEndParameter(1)) Dim pointsByParameter As New FieldDomainPointsByParameter(doubleList) Dim xyzList As New List(Of XYZ)() xyzList.Add(curve.ComputeDerivatives(0, True).BasisX.Normalize()) ' vectors will be tangent to the curve at its ends Dim vectorList As IList(Of VectorAtPoint) = New List(Of VectorAtPoint)() vectorList.Add(New VectorAtPoint(xyzList)) xyzList.Clear() xyzList.Add(curve.ComputeDerivatives(1, True).BasisX.Normalize().Negate()) vectorList.Add(New VectorAtPoint(xyzList)) Dim fieldValues As New FieldValues(vectorList)
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB..::..ValueAtPointBase
Autodesk.Revit.DB.Analysis..::..VectorAtPoint
Autodesk.Revit.DB..::..ValueAtPointBase
Autodesk.Revit.DB.Analysis..::..VectorAtPoint