Sets the data to reference an IfcLocalPlacement handle when creating the extrusion.
Side effect: will set ReuseLocalPlacement to true.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public void SetLocalPlacement( IFCAnyHandle localPlacement ) |
Visual Basic |
---|
Public Sub SetLocalPlacement ( _ localPlacement As IFCAnyHandle _ ) |
Visual C++ |
---|
public: void SetLocalPlacement( IFCAnyHandle^ localPlacement ) |
Parameters
- localPlacement
- Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The IfcLocalPlacement handle.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |