A utility object that is used to pass information related to extrusion creation.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public class IFCExtrusionCreationData : IDisposable |
Visual Basic |
---|
Public Class IFCExtrusionCreationData _ Implements IDisposable |
Visual C++ |
---|
public ref class IFCExtrusionCreationData : IDisposable |
Remarks
This class accepts input used to attempt to create an extrusion (possibly with openings) from Revit geometry.
The output contains information about the created extrusion and its openings. The information set is used to
generate properties for the extruded body and related opening elements in the IFC file.
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB.IFC..::..IFCExtrusionCreationData
Autodesk.Revit.DB.IFC..::..IFCExtrusionCreationData