SpaceSet Class

A set that can contain any type of object.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DB.MechanicalSpaceSet

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class SpaceSet : APIObject, IEnumerable

The SpaceSet type exposes the following members.

Constructors
 NameDescription
Public methodSpaceSetInitializes a new instance of the SpaceSet class
Top
Properties
 NameDescription
Public propertyIsEmptyTest to see if the set is empty.
Public propertySizeReturns the number of objects that are in the set.
Top
Methods
 NameDescription
Public methodClearRemoves every item from the set, rendering it empty.
Public methodContains 
Public methodErase 
Public methodForwardIteratorRetrieve a forward moving iterator to the set.
Public methodGetEnumeratorRetrieve a forward moving iterator to the set.
Public methodInsert 
Public methodReverseIteratorRetrieve a backward moving iterator to the set.
Top
See Also