ExporterIFCUtilsExportSlabAsExtrusion Method |
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool ExportSlabAsExtrusion(
ExporterIFC exporterIFC,
Element pCeilingAndFloor,
GeometryElement pGRep,
IFCTransformSetter pTmpTrfSetter,
IFCAnyHandle localPlacement,
out IList<IFCAnyHandle> localPlacementAnyArr,
out IList<IFCAnyHandle> reps,
out IList<IList<CurveLoop>> extrusionLoops,
out IList<IFCExtrusionCreationData> loopExtraParams,
Plane plane
)
Public Shared Function ExportSlabAsExtrusion (
exporterIFC As ExporterIFC,
pCeilingAndFloor As Element,
pGRep As GeometryElement,
pTmpTrfSetter As IFCTransformSetter,
localPlacement As IFCAnyHandle,
<OutAttribute> ByRef localPlacementAnyArr As IList(Of IFCAnyHandle),
<OutAttribute> ByRef reps As IList(Of IFCAnyHandle),
<OutAttribute> ByRef extrusionLoops As IList(Of IList(Of CurveLoop)),
<OutAttribute> ByRef loopExtraParams As IList(Of IFCExtrusionCreationData),
plane As Plane
) As Boolean
public:
static bool ExportSlabAsExtrusion(
ExporterIFC^ exporterIFC,
Element^ pCeilingAndFloor,
GeometryElement^ pGRep,
IFCTransformSetter^ pTmpTrfSetter,
IFCAnyHandle^ localPlacement,
[OutAttribute] IList<IFCAnyHandle^>^% localPlacementAnyArr,
[OutAttribute] IList<IFCAnyHandle^>^% reps,
[OutAttribute] IList<IList<CurveLoop^>^>^% extrusionLoops,
[OutAttribute] IList<IFCExtrusionCreationData^>^% loopExtraParams,
Plane^ plane
)
static member ExportSlabAsExtrusion :
exporterIFC : ExporterIFC *
pCeilingAndFloor : Element *
pGRep : GeometryElement *
pTmpTrfSetter : IFCTransformSetter *
localPlacement : IFCAnyHandle *
localPlacementAnyArr : IList<IFCAnyHandle> byref *
reps : IList<IFCAnyHandle> byref *
extrusionLoops : IList<IList<CurveLoop>> byref *
loopExtraParams : IList<IFCExtrusionCreationData> byref *
plane : Plane -> bool
Parameters
- exporterIFC ExporterIFC
-
- pCeilingAndFloor Element
-
- pGRep GeometryElement
-
- pTmpTrfSetter IFCTransformSetter
-
- localPlacement IFCAnyHandle
-
- localPlacementAnyArr IListIFCAnyHandle
-
- reps IListIFCAnyHandle
-
- extrusionLoops IListIListCurveLoop
-
- loopExtraParams IListIFCExtrusionCreationData
-
- plane Plane
-
Return Value
Boolean
See Also