NullParameterValue Class

A class that represent an empty (null) value of a parameter element.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBParameterValue
    Autodesk.Revit.DBNullParameterValue

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class NullParameterValue : ParameterValue

The NullParameterValue type exposes the following members.

Constructors
 NameDescription
Public methodNullParameterValue Default constructor
Top
Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from ParameterValue)
Top
Methods
 NameDescription
Public methodCopy Makes an identical copy of the given parameter value.
(Inherited from ParameterValue)
Public methodDispose
(Inherited from ParameterValue)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodIsEqual Tests equality with another instance of the same class.
(Inherited from ParameterValue)
Public methodIsSameType Tests another instance is of the same value type.
(Inherited from ParameterValue)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also