ParameterUtilsDownloadParameterOptions Method |
Retrieves settings associated with the given parameter from the Parameters Service.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static ParameterDownloadOptions DownloadParameterOptions(
ForgeTypeId parameterTypeId
)
Public Shared Function DownloadParameterOptions (
parameterTypeId As ForgeTypeId
) As ParameterDownloadOptions
public:
static ParameterDownloadOptions^ DownloadParameterOptions(
ForgeTypeId^ parameterTypeId
)
static member DownloadParameterOptions :
parameterTypeId : ForgeTypeId -> ParameterDownloadOptions
Parameters
- parameterTypeId ForgeTypeId
-
Parameter identifier.
Return Value
ParameterDownloadOptions
Settings associated with a parameter.
Exceptions
Remarks
The settings associated with a parameter definition are accessible only to an authorized user.
To retrieve them, the user must be signed in.
See Also