WorksetFilter Class

A base class for a type of filter that accepts or rejects worksets based upon criteria.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBWorksetFilter
    Autodesk.Revit.DBWorksetKindFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class WorksetFilter : IDisposable

The WorksetFilter type exposes the following members.

Properties
 NameDescription
Public propertyIncludeStandaloneWorksetsOnly True if the results of the filter only match stand-alone worksets; worksets that are not stand-alone will be rejected.
Public propertyInverted True if the results of the filter are inverted; worksets that would normally be accepted by this filter will be rejected, and worksets that would normally be rejected will be accepted.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the WorksetFilter
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also