WorksetKindFilter Class

A filter used to match worksets of the given WorksetKind.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBWorksetFilter
    Autodesk.Revit.DBWorksetKindFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class WorksetKindFilter : WorksetFilter

The WorksetKindFilter type exposes the following members.

Constructors
 NameDescription
Public methodWorksetKindFilter(WorksetKind) Constructs a new instance of WorksetKindFilter filter to match worksets of the given WorksetKind.
Public methodWorksetKindFilter(WorksetKind, Boolean) Constructs a new instance of WorksetKindFilter filter to match worksets of the given WorksetKind.
Top
Properties
 NameDescription
Public propertyIncludeStandaloneWorksetsOnly True if the results of the filter only match stand-alone worksets; worksets that are not stand-alone will be rejected.
(Inherited from WorksetFilter)
Public propertyInverted True if the results of the filter are inverted; worksets that would normally be accepted by this filter will be rejected, and worksets that would normally be rejected will be accepted.
(Inherited from WorksetFilter)
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from WorksetFilter)
Public propertyWorksetKind The WorksetKind.
Top
Methods
 NameDescription
Public methodDispose
(Inherited from WorksetFilter)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
This filter is a quick filter.
See Also