ExporterIFCUtilsCreateSubElementGUID Method |
Creates a consistent GUID for an IFC entity related to a Revit element.
A "related" sub-element is one that is unique for a given type of element, and can
therefore by identified by a simple index value (e.g. PSet_Wall_Common property set for a wall.)
The index value 0 is reserved, as this would generate the GUID of the element itself.
A listing of known sub-elements is contained in IFCSubElementEnums.cs; it is
expected that this list would be maintained up-to-date, instead of passing arbitrary values
into this function.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static string CreateSubElementGUID(
Element pElement,
int subElementIndex
)
Public Shared Function CreateSubElementGUID (
pElement As Element,
subElementIndex As Integer
) As String
public:
static String^ CreateSubElementGUID(
Element^ pElement,
int subElementIndex
)
static member CreateSubElementGUID :
pElement : Element *
subElementIndex : int -> string
Parameters
- pElement Element
-
The element.
- subElementIndex Int32
-
The global index for this sub-element.
Return Value
String
The guid string.
Exceptions
See Also