BuiltInFailuresCopyPasteFailures Class

Failures about CopyPasteFailures.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBBuiltInFailuresCopyPasteFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class CopyPasteFailures

The BuiltInFailuresCopyPasteFailures type exposes the following members.

Properties
 NameDescription
Public propertyStatic memberCannotCopyAttachedType Cannot copy attached detail group type without copying the model group type it refers to.
Public propertyStatic memberCannotCopyAttachedTypeWarn Cannot copy attached detail group type without copying the model group type it refers to.
Public propertyStatic memberCannotCopyBetweenFamilyAndProjectCorruption Can't copy between Family and Project.
Public propertyStatic memberCannotCopyBetweenFamilyAndProjectError Can't copy between Family and Project.
Public propertyStatic memberCannotCopyCurtainWallGridLines Curtain wall grid lines currently cannot be copied.
Public propertyStatic memberCannotCopyDependentView Dependent views cannot be copied.
Public propertyStatic memberCannotCopyDetails Can't copy some or all of the detailing with the view.
Public propertyStatic memberCannotCopyDueToBackgroundCalculation Cannot copy dragged elements while background calculations are in progress.
Public propertyStatic memberCannotCopyDuplicates Can't paste duplicate types. Only non duplicate types will be pasted.
Public propertyStatic memberCannotCopyElevationArrow To duplicate Elevations, copy the elevation symbol in a plan view.
Public propertyStatic memberCannotCopyElevationArrowWarn To duplicate Elevations, copy the elevation symbol in a plan view.
Public propertyStatic memberCannotCopyFamilyName Can't [Action] because Family '[Family Name]' is different in the two documents. Update the documents to contain the same version of the Family.
Public propertyStatic memberCannotCopyFromProjectAndLink Can't Copy to Clipboard elements from the project and a link instance at the same time. Only elements from the project will be copied.
Public propertyStatic memberCannotCopyGridLines Curtain grid lines cannot be copied. If you are trying to copy the curtain wall, try using tab to select entire wall.
Public propertyStatic memberCannotCopyGridLinesWarn Curtain grid lines cannot be copied. If you are trying to copy the curtain wall, try using tab to select entire wall.
Public propertyStatic memberCannotCopyImportInstancesAcrossProjects Linked Imported Files cannot be copied across projects. All non-RVT linked files will be pasted as imports instead.
Public propertyStatic memberCannotCopyIncompleteElement Can't copy part of element
Public propertyStatic memberCannotCopyIncompleteElementWarn Can't copy part of element
Public propertyStatic memberCannotCopyJoinedGeometry Joined solid geometry cannot be copied as a whole. Instead, select the individual extrusions, etc., using Pick box or Ctrl-select and copy them.
Public propertyStatic memberCannotCopyJoinedGeometryWarn Joined solid geometry cannot be copied as a whole. Instead, select the individual extrusions, etc., using Pick box or Ctrl-select and copy them.
Public propertyStatic memberCannotCopyLocked Can't copy pinned element.
Public propertyStatic memberCannotCopyLockedWarn Can't copy pinned element.
Public propertyStatic memberCannotCopyMassing A massing cannot be copied. Copy the elements within the massing instead.
Public propertyStatic memberCannotCopyMassingWarn A massing cannot be copied. Copy the elements within the massing instead.
Public propertyStatic memberCannotCopyMullions Mullions and panels cannot be copied without copying the entire curtain wall.
Public propertyStatic memberCannotCopyMullionsError Mullions and panels cannot be copied without copying the entire curtain wall.
Public propertyStatic memberCannotCopyMullionsWarn Mullions and panels cannot be copied without copying the entire curtain wall.
Public propertyStatic memberCannotCopyMultipleSketchParents Copying elements from unrelated Workplanes together is not supported in families. Try copying elements separately.
Public propertyStatic memberCannotCopyMustBeUnique Element must be unique.
Public propertyStatic memberCannotCopyMustBeUniqueWarn Element must be unique.
Public propertyStatic memberCannotCopyNestedLinks To copy a nested link, use Copy to Clipboard or Move Copy.
Public propertyStatic memberCannotCopyNoAttachedParent Attached Detail Group can't be copied without its Model Group
Public propertyStatic memberCannotCopyNoAttachedParentWarn Attached Detail Group can't be copied without its Model Group
Public propertyStatic memberCannotCopyNoParents Can't Copy to Clipboard because of relationships between Elements
Public propertyStatic memberCannotCopyNoReferences Elements can't be copied because they will lose their References.
Public propertyStatic memberCannotCopyRevolveAxis The axis cannot be copied.
Public propertyStatic memberCannotCopyRevolveAxisWarn The axis cannot be copied.
Public propertyStatic memberCannotCopySelectedPick The element being dragged can't be copied.
Public propertyStatic memberCannotCopySelection Cannot copy selection.[Description]
Public propertyStatic memberCannotCopySketchGrid Work Planes cannot be copied.
Public propertyStatic memberCannotCopySketchGridWarn Work Planes cannot be copied.
Public propertyStatic memberCannotCopySunAndShadowSettings SunAndShadowSettings cannot be copied.
Public propertyStatic memberCannotCopySunAndShadowSettingsWarn SunAndShadowSettings cannot be copied.
Public propertyStatic memberCannotCopyWallPanels Cannot copy wall panels unless their parent wall is also being copied.
Public propertyStatic memberCannotCopyWallPanelsWarn Cannot copy wall panels unless their parent wall is also being copied.
Public propertyStatic memberCannotCopyZone A Zone cannot be copied.
Public propertyStatic memberCannotCopyZoneWarn A Zone cannot be copied.
Public propertyStatic memberCannotDuplicate Elements can't be duplicated
Public propertyStatic memberCannotDuplicateDesignOption Can't duplicate Design Option.
Public propertyStatic memberCannotDuplicateInOption Elements can't be duplicated in a secondary Option
Public propertyStatic memberCannotDuplicateInOptionWarn Elements can't be duplicated in a secondary Option
Public propertyStatic memberCannotDuplicateType Cannot Duplicate Type.
Public propertyStatic memberCannotDuplicateWarn Elements can't be duplicated
Public propertyStatic memberCannotFinalizeClusterInconsistency Can't finalize because dependent element failed to finalize.
Public propertyStatic memberCannotFinalizeOrphanSerf Can't finalize Group member without finalizing the entire Group.
Public propertyStatic memberCannotPasteAlignedAny Can't Paste Aligned.
Public propertyStatic memberCannotPasteAlignedCorruption Can't Paste Aligned these elements in this view.
Public propertyStatic memberCannotPasteAlignedError Can't Paste Align these elements in this view.
Public propertyStatic memberCannotPasteAlignedSomeLevels Can't Paste Aligned to some views.
Public propertyStatic memberCannotPasteAssemblyView Can't paste assembly view because its associated assembly instance is not available.
Public propertyStatic memberCannotPasteCircularLinks The pasted selection includes a linked instance of this file '[Name]'. A file cannot link itself, so the link was not pasted.
Public propertyStatic memberCannotPasteCurtainGridLine Can't paste Curtain Grid Line.
Public propertyStatic memberCannotPasteDifferentViewSpecificElements Cannot paste view-specific elements from different views.
Public propertyStatic memberCannotPasteElemInViewError Cannot paste the contents into %1!s! view. Attempt to paste into an appropriate view.
Public propertyStatic memberCannotPasteInSketch Can't paste elements into sketch.
Public propertyStatic memberCannotPasteInView Cannot paste the contents into %1!s! view. Attempt to paste into an appropriate view.
Public propertyStatic memberCannotPasteInViewError Cannot paste the contents into %1!s! view. Attempt to paste into an appropriate view.
Public propertyStatic memberCannotPasteModelPlusViewSpecificElementsIntoView Cannot paste view-specific model plus into view.
Public propertyStatic memberCannotPasteNoLevelAbove Can't paste these elements at this height because there is no Level above to Reference.
Public propertyStatic memberCannotPasteNoLevelBelow Can't paste these elements at this height because there is no Level below to reference.
Public propertyStatic memberCannotPasteNoWorkplane Can't paste because there is no corresponding Work Plane. Set workplane or switch to view with appropriate workplane.
Public propertyStatic memberCannotPasteRoomsInNonPlanViews [Rooms] can only be pasted in Plan or Ceiling Plan views.
Public propertyStatic memberCannotPasteToSheet Elements copied to Sheets can only be copied from other Sheets.
Public propertyStatic memberCannotPasteViewSpecElemsFromDiffViews Cannot paste view-specific elements from different views.
Public propertyStatic memberCannotPasteViewSpecificElementsIntoPerspectiveView Can't paste view specific elements into perspective view.
Public propertyStatic memberCannotTransferProjectStandards These Project Standards cannot be transferred.[Description]
Public propertyStatic memberCantCopyBetweenModelAndAnnotFam Can't copy element(s) between Model and Annotation families.
Public propertyStatic memberCantCopyElemsToInplaceFam Can't copy element(s) to In Place family.
Public propertyStatic memberCantCopyFrom2dTo3dFam Can't copy 2D element(s) into a 3D family.
Public propertyStatic memberCantCopyFrom3dTo2dFam Can't copy 3D element(s) into a 2D family.
Public propertyStatic memberCantCopyFromDetailToProfileFam Can't copy Detail element(s) into a Profile family.
Public propertyStatic memberCantCopyLevelsOrRefPlanesToNonMassFamily Can't copy levels or reference planes to families that are not Mass families.
Public propertyStatic memberCantCopyStairsLevelHeightNotMatchInMS Can't copy stairs in Multistory Stairs due to level height doesn't match.
Public propertyStatic memberCantCopySymbolicElementToSelfOrientingFamily Cannot copy symbolic elements sketched in non-horizontal planes.
Public propertyStatic memberCopingColumnBeamFailure The support order for a beam/column connection has been changed. When a beam is supported by a column that same beam cannot be coped by the column. The existing coping has been removed.
Public propertyStatic memberCopyImposterContentError Cannot copy Render Appearance.
Public propertyStatic memberCopyImposterContentWarn Cannot copy Render Appearance.
Public propertyStatic memberCopyImposterLightError Light source cannot be copied!
Public propertyStatic memberCopyImposterLightWarn Light source cannot be copied!
Public propertyStatic memberElementRenamedOnPaste The loaded type "[Name]" has been renamed to "[New Name]" to avoid conflicts with the existing type.
Public propertyStatic memberFinalizedElementsWillBeDeleted Can't find new hosts for this Element.\nIt will be deleted on Finish Paste unless repositioned or rehosted.
Public propertyStatic memberFinalizedElementsWillBeDeletedWarn Can't find new hosts for this Element.\nIt will be deleted on Finish Paste unless repositioned or rehosted.
Public propertyStatic memberFinalizedElementsWillBeModified Can't find some new hosts for this Element.\nIt will lose references on Finish Paste unless repositioned or rehosted.
Public propertyStatic memberFinalizedElementsWillBeModifiedWarn Can't find some new hosts for this Element.\nIt will lose references on Finish Paste unless repositioned or rehosted.
Public propertyStatic memberLostReference A relationship between Elements in [Option Name] and [Reference Option Name] has been deleted. There is no corresponding relationship in the Primary [New Primary Option Name].
Public propertyStatic memberNoSketchPlane Can't paste because no Work Plane is defined in the View.
Public propertyStatic memberPasteInvisibleInView Selection is invisible in this view.
Public propertyStatic memberSomeElementsNotCopiedWarn Some elements were not copied.[Description]
Top
See Also