StructuralSectionUtilsGetStructuralElementDefinitionData Method |
Return structural element definition data.
Namespace: Autodesk.Revit.DB.Structure.StructuralSectionsAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static StructuralSectionErrorCode GetStructuralElementDefinitionData(
Document document,
ElementId elementId,
out StructuralElementDefinitionData data
)
Public Shared Function GetStructuralElementDefinitionData (
document As Document,
elementId As ElementId,
<OutAttribute> ByRef data As StructuralElementDefinitionData
) As StructuralSectionErrorCode
public:
static StructuralSectionErrorCode GetStructuralElementDefinitionData(
Document^ document,
ElementId^ elementId,
[OutAttribute] StructuralElementDefinitionData^% data
)
static member GetStructuralElementDefinitionData :
document : Document *
elementId : ElementId *
data : StructuralElementDefinitionData byref -> StructuralSectionErrorCode
Parameters
- document Document
-
The document that owns the beam, brace or structural column.
- elementId ElementId
-
ID of family instance for beam, brace or structural column.
- data StructuralElementDefinitionData
-
Structural element definition data.
Return Value
StructuralSectionErrorCode
Success code is returned if StructuralElementDefinitionData was provided successfully, error code otherwise.
Exceptions
Remarks
This information is provided only for beams, braces and structural columns.
See Also