StructuralSectionErrorCode Enumeration |
Error codes for StructuralSection related operations.
Namespace: Autodesk.Revit.DB.Structure.StructuralSectionsAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum StructuralSectionErrorCode
Public Enumeration StructuralSectionErrorCode
public enum class StructuralSectionErrorCode
type StructuralSectionErrorCode
MembersMember name | Value | Description |
---|
Success | 0 | |
Failure | 1 | |
ShapeNotRecognized | 2 | |
IncompleteDefinition | 3 | |
ElementNotSupported | 4 | |
MediumDetailShapeHasRounding | 5 | |
MediumAndFineDetailShapesAreInconsistent | 6 | |
ElementHasIndependentJustification | 7 | |
See Also