SweptProfileGetDrivingCurve Method |
Provides access to the curve that dictates the path of the swept profile.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic Curve GetDrivingCurve()
Public Function GetDrivingCurve As Curve
public:
Curve^ GetDrivingCurve()
member GetDrivingCurve : unit -> Curve
Return Value
Curve
A curve that defines the path of the swept profile.
Remarks
The profile may not be swept the entire length of this curve. One should check the
set back properties on this object to locate how far the actual sweep is from the ends of the curve.
See Also