SweptProfile Class

Represents an extruded profile swept along a driving curve.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBSweptProfile

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class SweptProfile : IDisposable

The SweptProfile type exposes the following members.

Properties
 NameDescription
Public propertyEndSetBack The distance from the end of the driving curve to the point where the sweep actually ends.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyStartSetBack The distance from the start of the driving curve to the point where the sweep actually begins.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the SweptProfile
Public methodGetDrivingCurve Provides access to the curve that dictates the path of the swept profile.
Public methodGetSweptProfile Returns an object that describes the profile that is swept along the driving curve.
Top
Remarks
Elements such as beams may be formed from a profile that has been swept along a curve. This class represents such a form and is used to access the cross section and the underlying curve that make up the Element.
See Also