LoadedFamilyIntegrityCheckCheckAllFamilies Method |
Check that all families loaded in the host document have their content documents.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool CheckAllFamilies(
Document ADoc,
ISet<ElementId> corruptFamilyIds
)
Public Shared Function CheckAllFamilies (
ADoc As Document,
corruptFamilyIds As ISet(Of ElementId)
) As Boolean
public:
static bool CheckAllFamilies(
Document^ ADoc,
ISet<ElementId^>^ corruptFamilyIds
)
static member CheckAllFamilies :
ADoc : Document *
corruptFamilyIds : ISet<ElementId> -> bool
Parameters
- ADoc Document
-
The host document.
- corruptFamilyIds ISetElementId
-
Return ids of families that need to be reloaded because their content documents are missing.
Return Value
Boolean
Returns true if all loaded families have their content documents.
Exceptions
See Also