CurveArrayIterator Class

An iterator to a curve array.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBCurveArrayIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public abstract class CurveArrayIterator : APIObject, 
	IEnumerator

The CurveArrayIterator type exposes the following members.

Constructors
 NameDescription
Public methodCurveArrayIteratorFor Internal Use Only.
Top
Properties
 NameDescription
Public propertyCurrentRetrieves the item that is the current focus of the iterator.
Top
Methods
 NameDescription
Public methodMoveNextMove the iterator one item forward.
Public methodResetBring the iterator back to the start of the array.
Top
See Also