IFCLevelInfoCreate Method |
Creates an IFCLevelInfo.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static IFCLevelInfo Create(
IFCAnyHandle buildingStorey,
IFCAnyHandle localPlacement,
double height,
double elevation,
double scaleFactor,
bool isPrimaryLevel
)
Public Shared Function Create (
buildingStorey As IFCAnyHandle,
localPlacement As IFCAnyHandle,
height As Double,
elevation As Double,
scaleFactor As Double,
isPrimaryLevel As Boolean
) As IFCLevelInfo
public:
static IFCLevelInfo^ Create(
IFCAnyHandle^ buildingStorey,
IFCAnyHandle^ localPlacement,
double height,
double elevation,
double scaleFactor,
bool isPrimaryLevel
)
static member Create :
buildingStorey : IFCAnyHandle *
localPlacement : IFCAnyHandle *
height : float *
elevation : float *
scaleFactor : float *
isPrimaryLevel : bool -> IFCLevelInfo
Parameters
- buildingStorey IFCAnyHandle
-
The building storey handle (IfcBuildingStorey).
- localPlacement IFCAnyHandle
-
The local placement handle (IfcLocalPlacement).
- height Double
-
The height of the level.
- elevation Double
-
The elevation of the level.
- scaleFactor Double
-
The scale factor.
- isPrimaryLevel Boolean
-
True if this is primary level, false otherwise.
Return Value
IFCLevelInfo
The IFCLevelInfo object.
Exceptions
See Also