MultistoryStairsUnpin Method

Removes a particular story of the stairs (identified by its base level id) from a stairs group.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public Stairs Unpin(
	ElementId levelId
)

Parameters

levelId  ElementId
The base level id. If the level id belongs to the base level of a unpinned stairs element, it returns the stairs id directly.

Return Value

Stairs
The unpinned stairs element.
Exceptions
ExceptionCondition
ArgumentException There is no stairs instance at the given base levelId.
ArgumentNullException A non-optional argument was null
Remarks
If the story at the given level is in a group, it will separate an individual stairs element from the group with "unpinned" status. Changes you make to the returned stairs element will not affect any other stairs. If the story of stairs is already an individual stairs element, the status will be changed to "unpinned".
See Also