ConfigurationReloadInfo Class

This object contains information returned by a reload of the fabrication configuration.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBConfigurationReloadInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ConfigurationReloadInfo : IDisposable

The ConfigurationReloadInfo type exposes the following members.

Constructors
 NameDescription
Public methodConfigurationReloadInfo Constructor.
Top
Properties
 NameDescription
Public propertyDisconnects The number of disconnections caused by the reload.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyOutOfDatePartCount The number of fabrication part instances that had newer versions and were out of date.
Public propertyProfileNotAvailable The current profile is not available in the disk configuration.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the ConfigurationReloadInfo
Public methodGetConnectivityValidation Returns information about the post-reload connectivity validation.
Public methodGetCustomDataChangedElements Gets a list of ElementIds of fabrication parts that had custom data updated during the reload.
Public methodGetOutOfDatePartStatus Access reload information for out of date part.
Top
See Also