BalusterPlacementBalusterPerTreadFamilyId Property

The id of baluster per tread family.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementId BalusterPerTreadFamilyId { get; set; }

Property Value

ElementId
Exceptions
ExceptionCondition
ArgumentException When setting this property: The balusterPerTreadFamilyId doesn't refer to a valid baluster family.
ArgumentNullException When setting this property: A non-optional argument was null
Remarks
The property defines a baluster family type which is used for creation of balusters on treads. The number of such balusters is set by "BalusterPerTreadNumber" property. It works only for stairs which have treads and have "UseBalusterPerTreadOnStairs" set.
See Also