SpatialElementBoundaryOptions Class

Options that can be passed to a SpatialElementBoundaryCalculator to influence the results of the calculation.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBSpatialElementBoundaryOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class SpatialElementBoundaryOptions : IDisposable

The SpatialElementBoundaryOptions type exposes the following members.

Constructors
 NameDescription
Public methodSpatialElementBoundaryOptions Constructs default options for calculation of the geometry of spatial elements (rooms, spaces).
Top
Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertySpatialElementBoundaryLocation The boundary of spatial element for geometry calculation.
Public propertyStoreFreeBoundaryFaces Indicates whether to include the free boundary faces in the result.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the SpatialElementBoundaryOptions
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also