ExternalFileUtilsGetExternalFileReference Method |
Gets the external file referencing data for the given element.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static ExternalFileReference GetExternalFileReference(
Document aDoc,
ElementId elemId
)
Public Shared Function GetExternalFileReference (
aDoc As Document,
elemId As ElementId
) As ExternalFileReference
public:
static ExternalFileReference^ GetExternalFileReference(
Document^ aDoc,
ElementId^ elemId
)
static member GetExternalFileReference :
aDoc : Document *
elemId : ElementId -> ExternalFileReference
Parameters
- aDoc Document
-
A Revit Document.
- elemId ElementId
-
The element whose external file reference we want.
Return Value
ExternalFileReference
An object containing path and type information for the given element's external file.
ExceptionsException | Condition |
---|
ArgumentException |
The element elemId does not exist in the document
-or-
elemId does not represent an external file reference.
|
ArgumentNullException |
A non-optional argument was null
|
See Also