IExportContext2DOnFaceSilhouette2D Method |
This method is called when a Face silhouette is being output.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
SyntaxRenderNodeAction OnFaceSilhouette2D(
FaceSilhouetteNode node
)
Function OnFaceSilhouette2D (
node As FaceSilhouetteNode
) As RenderNodeAction
RenderNodeAction OnFaceSilhouette2D(
FaceSilhouetteNode^ node
)
abstract OnFaceSilhouette2D :
node : FaceSilhouetteNode -> RenderNodeAction
Parameters
- node FaceSilhouetteNode
-
An output node that represents a Face silhouette.
Return Value
RenderNodeAction
Return RenderNodeAction.Proceed if you wish to receive tessellated geometry
(line or polyline segments) for this face silhouette, or otherwise return RenderNodeAction.Skip.
Note: if the export is performed for the view in non-Wireframe display style
tesselated geometry will be output regardless of the return value.
RemarksNote that this method is invoked only if the custom exporter
was set up to include geometric objects in the output stream.
See IncludeGeometricObjects for mode details.
Note: if the export is performed for the view in non-Wireframe display style
this method will be called regardless of whether the object will be eventially output,
i.e. even if it's occluded by another element.
See Also