RenderNodeAction Enumeration |
Enumerated actions for processing a render node during custom export.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum RenderNodeAction
Public Enumeration RenderNodeAction
public enum class RenderNodeAction
MembersMember name | Value | Description |
---|
Proceed | 0 |
Instruct the exporter to go on with processing the node. It means
the exporter will continue handling the node by processing all its
child nodes, if it has any, and their geometry where it is relevant.
|
Skip | 1 |
Instruct the exporter to skip the node. It means the exporter
will not process any child nodes (nor the geometry) of the node.
The respective end-node notification will still be invoked though.
|
See Also