ExporterIFCGetMaterialIdForCurrentExportState Method |
This gets the material id that is associated with the element in the current export state.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementId GetMaterialIdForCurrentExportState()
Public Function GetMaterialIdForCurrentExportState As ElementId
public:
ElementId^ GetMaterialIdForCurrentExportState()
member GetMaterialIdForCurrentExportState : unit -> ElementId
Return Value
ElementId
The material id.
Remarks
Even though there could be several materials associated with the element (set during PushExportState()),
unless the element has support for IfcMaterialLayerSet, IFC output will include only this one.
See Also