ExporterIFCUtilsGetLegacyStairsProperties Method |
Returns one or more properties for legacy (created in R2012 or before) Stairs.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static void GetLegacyStairsProperties(
ExporterIFC exporterIFC,
Element pElement,
out int pNumRisers,
out int pNumTreads,
out double pRiserHeight,
out double pTreadLength,
out double pMinTreadLength,
out double pNosingLength,
out double pWaistThickness
)
Public Shared Sub GetLegacyStairsProperties (
exporterIFC As ExporterIFC,
pElement As Element,
<OutAttribute> ByRef pNumRisers As Integer,
<OutAttribute> ByRef pNumTreads As Integer,
<OutAttribute> ByRef pRiserHeight As Double,
<OutAttribute> ByRef pTreadLength As Double,
<OutAttribute> ByRef pMinTreadLength As Double,
<OutAttribute> ByRef pNosingLength As Double,
<OutAttribute> ByRef pWaistThickness As Double
)
public:
static void GetLegacyStairsProperties(
ExporterIFC^ exporterIFC,
Element^ pElement,
[OutAttribute] int% pNumRisers,
[OutAttribute] int% pNumTreads,
[OutAttribute] double% pRiserHeight,
[OutAttribute] double% pTreadLength,
[OutAttribute] double% pMinTreadLength,
[OutAttribute] double% pNosingLength,
[OutAttribute] double% pWaistThickness
)
static member GetLegacyStairsProperties :
exporterIFC : ExporterIFC *
pElement : Element *
pNumRisers : int byref *
pNumTreads : int byref *
pRiserHeight : float byref *
pTreadLength : float byref *
pMinTreadLength : float byref *
pNosingLength : float byref *
pWaistThickness : float byref -> unit
Parameters
- exporterIFC ExporterIFC
-
The exporter.
- pElement Element
-
the legacy stair.
- pNumRisers Int32
-
Number of Risers in the Stair.
- pNumTreads Int32
-
Number of Treads in the Stair.
- pRiserHeight Double
-
Riser Height of the risers in the Stair.
- pTreadLength Double
-
Tread length of the treads in the Stair.
- pMinTreadLength Double
-
Minimum Tread length of the treads in the Stair.
- pNosingLength Double
-
Nosing length of the treads in the Stair.
- pWaistThickness Double
-
Waist thickness of the flight of stair.
Exceptions
See Also