GeometryCreationUtilities Class

A utility that allows construction of basic solid shapes.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBGeometryCreationUtilities

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class GeometryCreationUtilities

The GeometryCreationUtilities type exposes the following members.

Methods
 NameDescription
Public methodStatic memberCreateBlendGeometry(CurveLoop, CurveLoop, ICollectionVertexPair) Creates a solid by blending two closed curve loops lying in non-coincident planes.
Public methodStatic memberCreateBlendGeometry(CurveLoop, CurveLoop, ICollectionVertexPair, SolidOptions) Creates a solid by blending two closed curve loops lying in non-coincident planes.
Public methodStatic memberCreateExtrusionGeometry(IListCurveLoop, XYZ, Double) Creates a solid by linearly extruding one or more closed coplanar curve loops.
Public methodStatic memberCreateExtrusionGeometry(IListCurveLoop, XYZ, Double, SolidOptions) Creates a solid by linearly extruding one or more closed coplanar curve loops.
Public methodStatic memberCreateFixedReferenceSweptGeometry(CurveLoop, Int32, Double, IListCurveLoop, XYZ) Creates a solid by sweeping one or more closed coplanar curve loops along a path while keeping the profile plane oriented so that a line in the plane that is initially perpendicular to a given fixed direction remains perpendicular as the profile is swept along the path.
Public methodStatic memberCreateFixedReferenceSweptGeometry(CurveLoop, Int32, Double, IListCurveLoop, XYZ, SolidOptions) Creates a solid by sweeping one or more closed coplanar curve loops along a path while keeping the profile plane oriented so that a line in the plane that is initially perpendicular to a given fixed direction remains perpendicular as the profile is swept along the path.
Public methodStatic memberCreateLoftGeometry Creates a solid or open shell geometry by lofting between a sequence of curve loops.
Public methodStatic memberCreateRevolvedGeometry(Frame, IListCurveLoop, Double, Double) Creates a solid of revolution by revolving a set of closed curve loops around an axis by a specified angle.
Public methodStatic memberCreateRevolvedGeometry(Frame, IListCurveLoop, Double, Double, SolidOptions) Creates a solid of revolution by revolving a set of closed curve loops around an axis by a specified angle.
Public methodStatic memberCreateSweptBlendGeometry(Curve, IListDouble, IListCurveLoop, IListICollectionVertexPair) Creates a solid by simultaneously sweeping and blending two or more closed planar curve loops along a single curve.
Public methodStatic memberCreateSweptBlendGeometry(Curve, IListDouble, IListCurveLoop, IListICollectionVertexPair, SolidOptions) Creates a solid by simultaneously sweeping and blending two or more closed planar curve loops along a single curve.
Public methodStatic memberCreateSweptGeometry(CurveLoop, Int32, Double, IListCurveLoop) Creates a solid by sweeping one or more closed coplanar curve loops along a path.
Public methodStatic memberCreateSweptGeometry(CurveLoop, Int32, Double, IListCurveLoop, SolidOptions) Creates a solid by sweeping one or more closed coplanar curve loops along a path.
Top
Remarks
The shapes created by these utilities are not a part of any Revit document, but can be used in conjunction with other geometric utilities from within API applications.
See Also