GeometryCreationUtilitiesCreateBlendGeometry(CurveLoop, CurveLoop, ICollectionVertexPair) Method |
Creates a solid by blending two closed curve loops lying in non-coincident planes.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static Solid CreateBlendGeometry(
CurveLoop firstLoop,
CurveLoop secondLoop,
ICollection<VertexPair> vertexPairs
)
Public Shared Function CreateBlendGeometry (
firstLoop As CurveLoop,
secondLoop As CurveLoop,
vertexPairs As ICollection(Of VertexPair)
) As Solid
public:
static Solid^ CreateBlendGeometry(
CurveLoop^ firstLoop,
CurveLoop^ secondLoop,
ICollection<VertexPair^>^ vertexPairs
)
static member CreateBlendGeometry :
firstLoop : CurveLoop *
secondLoop : CurveLoop *
vertexPairs : ICollection<VertexPair> -> Solid
Parameters
- firstLoop CurveLoop
-
The first curve loop. The loop must be a closed planar loop without intersections or degeneracies. No orientation conditions are imposed. The loop may not contain just one closed curve - split such a loop into two or more curves beforehand.
- secondLoop CurveLoop
-
The second curve loop, satisfying the same conditions as the first loop.
The planes of the first and second loops must not be coincident, but they need not be parallel.
- vertexPairs ICollectionVertexPair
-
This input specifies how the two profile loops should be connected.
If null, the function chooses vertex connections that will result in a geometrically reasonable blend.
Return Value
Solid
The requested solid.
ExceptionsException | Condition |
---|
ArgumentException |
The first profile CurveLoop do not satisfy the input requirements.
-or-
The second profile CurveLoop do not satisfy the input requirements.
|
ArgumentNullException |
A non-optional argument was null
|
See Also