Creates a new area
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic Area NewArea(
ViewPlan areaView,
UV point
)
Public Function NewArea (
areaView As ViewPlan,
point As UV
) As Area
public:
Area^ NewArea(
ViewPlan^ areaView,
UV^ point
)
member NewArea :
areaView : ViewPlan *
point : UV -> Area
Parameters
- areaView ViewPlan
- The view of area element.
- point UV
- The point which lies in the enclosed region of AreaBoundaryLines to put the new created Area
Return Value
Area
ExceptionsException | Condition |
---|
ArgumentException | Thrown if the area view does not exist in the given document. |
See Also