StairsLandingCanCreateAutomaticLanding Method |
Checks whether automatic landing(s) can be created between the given two stairs runs and
logically join(s) with the stairs runs.
Namespace: Autodesk.Revit.DB.ArchitectureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool CanCreateAutomaticLanding(
Document document,
ElementId firstRunId,
ElementId secondRunId
)
Public Shared Function CanCreateAutomaticLanding (
document As Document,
firstRunId As ElementId,
secondRunId As ElementId
) As Boolean
public:
static bool CanCreateAutomaticLanding(
Document^ document,
ElementId^ firstRunId,
ElementId^ secondRunId
)
static member CanCreateAutomaticLanding :
document : Document *
firstRunId : ElementId *
secondRunId : ElementId -> bool
Parameters
- document Document
-
The document that owns the stairs runs.
- firstRunId ElementId
-
The first stairs run.
- secondRunId ElementId
-
The second stairs run.
Return Value
Boolean
True if automatic landing(s) can be created between the two stairs runs, False otherwise.
Exceptions
Remarks
This only checks whether two stairs runs meet restriction to create automatic landing(s)
without checking the stairs edit scope and document modifiable.
See Also